Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Glow plugs on constantly
#1
So basically lus suddenly wouldnt start the other day. well not very well would eventuality go. so pulled the glow plugs out to replace and not one was working. thought while im here i may as well do the glow plug light mod as i have done in the past that keeps the light on even when it usually goes out.

So it clicks the glow plugs off when your pre heating then starts them up again while running and leaves them on. i know they usually stay on a bit but indefinitely i know they should not. any ideas?? 

So after fiddling about with relays. The one under the bonnet. Brown one. If I remove it the glow plugs work exactly as they should.
On a break from 306oc for personal reasons. If anyone needs or wants me most of you have my number and or facebook messenger
Thanks for the good times guys n gals. I might be back. Who knows.
Reply
Thanks given by:
#2
So finally figured out what happened. A 20 amp fuse had gone. Which seemed to control the brown relay under the bonnet that in turn was triggering the glow plug relay while running. No I don't have a wiring diagram to hand to see how they are all connected. All I know is that I can let Lu drive it again without burning out a set of new glow plugs.
On a break from 306oc for personal reasons. If anyone needs or wants me most of you have my number and or facebook messenger
Thanks for the good times guys n gals. I might be back. Who knows.
Reply
Thanks given by:
#3
Went to the car this morning. Still doing it. Super annoying.
On a break from 306oc for personal reasons. If anyone needs or wants me most of you have my number and or facebook messenger
Thanks for the good times guys n gals. I might be back. Who knows.
Reply
Thanks given by:
#4
So the story thickens. After being mega pissed off this morning. The light went out after 5 mins. But later it was only on for about a few seconds after running. Thinking I may have a dodgey temp sensor. I have a spare somewhere I think.
On a break from 306oc for personal reasons. If anyone needs or wants me most of you have my number and or facebook messenger
Thanks for the good times guys n gals. I might be back. Who knows.
Reply
Thanks given by:
#5
unplug the temp sender, see what happens

though the light should still go off even if post heat is working, so I'd change the big relay.
need a part number? http://public.servicebox.peugeot.com/ and http://service.citroen.com/ will sort you out.
Reply
Thanks given by:
#6
(10-07-2015, 11:49 AM)welshpug Wrote: unplug the temp sender, see what happens



though the light should still go off even if post heat is working, so I'd change the big relay.

I now have a big relay spare off one of my old motors and a sensor. I'll try big relay first though as cba to let coolant out.
On a break from 306oc for personal reasons. If anyone needs or wants me most of you have my number and or facebook messenger
Thanks for the good times guys n gals. I might be back. Who knows.
Reply
Thanks given by:
#7
you wont lose much if any.
need a part number? http://public.servicebox.peugeot.com/ and http://service.citroen.com/ will sort you out.
Reply
Thanks given by:
#8
I'll have to make it quick as the spare sensor is in my motor not in use anymore.
On a break from 306oc for personal reasons. If anyone needs or wants me most of you have my number and or facebook messenger
Thanks for the good times guys n gals. I might be back. Who knows.
Reply
Thanks given by:


Possibly Related Threads…
Thread Author Replies Views Last Post
  3 sets of glow plugs in 3 months???? HELP wdoyle2410 4 1,174 31-08-2018, 01:07 AM
Last Post: wdoyle2410
  Glow plugs unscrew but can't be removed EdAppleton 15 2,337 07-11-2016, 04:17 PM
Last Post: EdAppleton
  Glow Plugs or what?! timpug 7 1,567 23-11-2015, 08:00 AM
Last Post: timpug

Forum Jump:


Users browsing this thread: 1 Guest(s)