Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine light always on and had slight run-on
#1
Howdy all, hope stuffs going ok. Had an absolute awful day today, which was rounded off nicley by the 306 deciding to join in with playing up.

We were on the drive home after dropping off the land rover to have work done at the garage (so of course the only other car we have would play up) and everything was fine entire way home. Pull onto driveway and when I turn off the car I noticed she had a slight run on for about half a second, certainly no longer than 1 full second.

Took her out a couple of hours later for a 2 minute drive to shops, engine light was on the entire time, but she didn't have the run-on when turning off this time.

Anyone have any suggestions? I'll try and find a garage tomorrow that can read her fault codes, but not optimistic (doesnt seem to be worth their time for most local garages).

Aside from that theres been no other noticable symptoms, not down on power or any new noises. I did change the headlight bulbs 2 days ago incase that could somehow be related :p

EDIT: UPDATE: Couldn't find garage willing to look. But after further googling discoered the engine light goes away after 3 succesful startup/shutdowns. The problem never happened again, the light went out, been perfectly normal ever since. So going to assume the hiccup was just a stuck sensor or some other minor problem that, fingers crossed, won't come back any time soon.

Cheers Smile
Reply
Thanks given by:


Possibly Related Threads…
Thread Author Replies Views Last Post
  Engine management light came on ,, 306 hdi barnesy213 10 2,372 25-05-2016, 07:08 PM
Last Post: DeeTurbo
  Engine Management Light Is On Josh1994 1 774 05-07-2015, 06:46 AM
Last Post: Poodle
  slight engine issues jayspug86 14 1,670 10-02-2015, 11:07 PM
Last Post: Toms306

Forum Jump:


Users browsing this thread: 1 Guest(s)