Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Heating in 98 XSI
#1
Evening all. 

Got a heater issue in my xsi. Now there is no coolant leak, no head gasket issue as it has been down. All the heat in the pipes seems to be going where it is meant too. Am i right in thinking its the matrix that would probably be the issue? All the cables move as they are meant too  I get a little heat but not a great deal. But it will go to cold. 

Hasanyone had anything else similar?
Reply
Thanks given by:
#2
May well be that the matrix is full of crap, are both the pipes coming from the fire wall hot? I.e is it actually circulating though the matrix?

[Image: DSC_0190-Copy_zpsf093f84d.jpg]
Member of 99% warning or your nothing club!

Reply
Thanks given by:
#3
My rallye has never put out a great deal of heat. Have you replaced the thermostat at all?
Reply
Thanks given by:
#4
All my 306s heat up very quickly. The phase 1 from the start, the phase 2 and 3 need some time (only start heating when the engine is running for some time).

My guess would be a clogged heater. The unit that is behind the dashboard.
Reply
Thanks given by:
#5
its important to use coolant and not just water as this will lead to deterioration of the matrix much faster than coolant. I had a new matrix and it lasted less than a year after the guy who fitted it filled the car with water and not coolant :/
Reply
Thanks given by:
#6
Hi guys thanks for the reply. Bith pipes were coming off hot but i must admit i sold the car to. Someone aftera rally cross 306. I pick up a GTI 6 at the end of the month. Will upload photos when i get it
Reply
Thanks given by:


Possibly Related Threads…
Thread Author Replies Views Last Post
  heating system odd fault Piggy 6 874 26-05-2014, 04:53 PM
Last Post: Piggy
  Center console heating panel help. ginger3131 18 4,043 16-12-2012, 09:56 AM
Last Post: Welshy_Pete
  Heating Ben 8 1,641 27-10-2012, 06:36 PM
Last Post: Ben

Forum Jump:


Users browsing this thread: 1 Guest(s)