Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
s16 won't start
#1
Hello, few weeks ago I brought peugeot 306 s16. It won't start..
ECU not activating fuel pump relay.
No spark in spark plugs..
ECU shows no fault codes. 
Bosch mp 3.2(will write exact model tomorrow).
Maybe someone has ideas? Or maybe someone has full pinout?
Reply
Thanks given by:
#2
I don't suppose the impact switch has been tripped or unplugged? Red button in the engine bay mounted on the left-hand strut tower. I don't know if that would affect the spark though, i'm not so strong on petrol engines.

Any history on the vehicle, has it been stood for a long time?
306 HDi Deathtrap - 130bhp / 220lbft
...UPGRADING...



Reply
Thanks given by:
#3
A bit of time has passed since your first post so an update would be useful.  What have you tried so far?  Also, did you buy this as a non-runner?  Not sure if the immobiliser on the S16 disables both the fuel and the ignition system.  Unfortunately they're not very common over here so there won't be many people around with experience of them.

A noid light set like this is useful for testing whether the ECU is trying to control either the injectors or the coils, although it sounds like you've established none of them are being energised.  https://www.ebay.co.uk/itm/NOID-LIGHT-SE...rk:19:pf:0

I'm sure I've read somewhere that some of the early phase 1's had a switch under the bonnet that was part of the immobiliser system and required a key inserted in it.
Reply
Thanks given by:
#4
Hello. Sorry for not writing so long.
1) I removed impact switch.
2) I bought it with this problem. Previous owner stated that car was fine and left for a year. After that engine didn't start.
I have no signal to fuel relay and no signal to ,,commutators" (ignition modules). As for injectors I will be able to test signal in few weeks. My oscillograph is in service now.. ground signals for ecu looks fine. But I don't have full circuit for +12 to ecu. And don't know if ecu powering is ok. I mean if you have full ecu pinout it would be great. I could test if all + is in place and all gnd is in place... sorry for bad english
Reply
Thanks given by:
#5
I do not know this car.

Does it have the brown double relay?

This relay powers up the fuel pump in the tank and the ecu.

Nice you have a scope, but need the info which i cannot provide but I am sure info will be on here or provided if you ask.

sorry I cannot be more help.

car stored for a year with this fault, is the ign switch working ok, passing power when its turned on?
Reply
Thanks given by:
#6
Ign key working fine. Immo code accepted green led lights up. Fuel relay brown (in other cars can be grey) is ok. If I force signal tofuel pump relay from ecu connector fuel pump works. But ecu don't give signal to fuel pump and ignition modules.. this model is quite old and I want it in original shape.. I could fit some programmable ecu or try to write epprom without immo. But I want it original... that's why I am trying to get full ecu wiring and some help. Maybe some had similar problems. all help would be appreciated if you had no starting problems without faults stored with bosch MP3.2
Reply
Thanks given by:
#7
Hi again popas.  I don't have access to the pin-outs either. I've been thinking about signing up to a 1 month trial on Autodata tho,  to get hold of pin-outs & decent wiring diagrams for my own car. If I sign up any time soon I'll look up ECU pin-outs for an S16.

May be worth checking if you can get a trial with Autodata where you are. (They do provide a service in the Baltic countries). Here it's £9.99 for the first month but you have to cancel before the month is up. The renewal is really expensive otherwise!

Your English is excellent btw. Smile

...oh, & just realised I never said welcome to the club.
Reply
Thanks given by:
#8
(19-01-2019, 05:24 PM)Mighty306 Wrote: Hi again popas.  I don't have access to the pin-outs either. I've been thinking about signing up to a 1 month trial on Autodata tho,  to get hold of pin-outs & decent wiring diagrams for my own car. If I sign up any time soon I'll look up ECU pin-outs for an S16.

May be worth checking if you can get a trial with Autodata where you are. (They do provide a service in the Baltic countries). Here it's £9.99 for the first month but you have to cancel before the month is up. The renewal is really expensive otherwise!

Your English is excellent btw. Smile

...oh, & just realised I never said welcome to the club.

What car ecu pinout do you need?
Reply
Thanks given by:
#9
(20-01-2019, 04:14 PM)popas Wrote: [quote pid='624866' dateline='1547918673']
What car ecu pinout do you need?

[/quote]

I wanted the pin-out for a Bosch MP5.2 fitted to the 306 with the XU10J4R engine (2.0 16V Xsi).  I want to get printouts of lots of wiring diagrams too though.  The ones in Servicebox aren't easy to follow and the Heynes manual doesn't provide wiring diagrams for every model.
Reply
Thanks given by:
#10
Get the exact wiring diagrams as the haynes book of lies just show "typical" wiring diagrams some of which are incorrect !

Pug wiring diagrams can be a bit difficult at first but the more you use them the easier they become to read and understand, practice makes perfect.

As said i dont know this model ( still learning about the 306 2l hdi dw10 etc ) but the double relay is first energised by the ecu which then tells a different part of the  ecu thats its ok to proceed, the second part of the relay transmitting this info?? in a nutshell???
Reply
Thanks given by:
#11
(21-01-2019, 10:08 AM)pug306driver Wrote: Get the exact wiring diagrams as the haynes book of lies just show "typical" wiring diagrams some of which are incorrect !

Pug wiring diagrams can be a bit difficult at first but the more you use them the easier they become to read and understand, practice makes perfect.

As said i dont know this model ( still learning about the 306 2l hdi dw10 etc ) but the double relay is first energised by the ecu which then tells a different part of the  ecu thats its ok to proceed, the second part of the relay transmitting this info?? in a nutshell???

Yes. I saw that in wiring. First part of fuel relay is ok and on. Second part which activates fuel pump is not getting signal from ecu.. ecu gets +12 from first part of relay.  I am starting to think ecu is somehow faulty itself...
Reply
Thanks given by:
#12
Have you seen the tech info in the guides section.....

http://306oc.co.uk/forum/showthread.php?tid=32571

there is other info on here, i will check my "stick" as I saved stuff on there, for future reference......
Reply
Thanks given by:
#13
The GTI6 uses a different make of ECU from the S16 (& the 2 models weren't concurrent) so imagine the pin layouts aren't necessarily the same.
Reply
Thanks given by:
#14
Have already messaged the OP with this but thought had better post up here for completeness.  Originally came from here courtesy of a well-known member of this site also.  https://www.205gtidrivers.com/forums/top...u-pinouts/ .  There are a number of pinout files available but you need to be a member to download them.


.pdf   306 XU10J4 pinout.pdf (Size: 366.66 KB / Downloads: 3)
Reply
Thanks given by:
#15
Nice bit of info, but are the 2 pin out diagrams of the loom plug that plugs into the ecu?
Reply
Thanks given by:
#16
(25-01-2019, 09:55 AM)pug306driver Wrote: Nice bit of info, but are the 2 pin out diagrams of the loom plug that plugs into the ecu?

One's a diagram of the ECU side and the other the wire sire, so they are mirror images of each other.
Reply
Thanks given by:


Forum Jump:


Users browsing this thread: 1 Guest(s)