Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I think my turbo just died......
#1
Hi all, was just driving down the road in 3rd and all of a sudden the d turbo spluttered and stalled, it wouldn't start agin, but cranked over, eventually it started and a thick cloud of white smoke kicked out the exhaust, and a horrible noise from up front, needless to say i swiftly turned it off! I have noticed in the last few days a whine when accelerating but took no notice of it becuase im stupid! Im running a lucas and a t2 at 17 psi (well, I was!)so am i right in thinking the turbo has give up?

Any help would greatly be appreciated!!!

Cheers
Reply
Thanks given by:
#2
does sound like the turbo has died. good way to tell is remove the intercooler and see if its full of oil .
Reply
Thanks given by:
#3
Yeah gonna have a look when it stops raining, if it is the turbo, will i need to replace it with a t2 as thats what is in there or is the k14 the same fitment?
Reply
Thanks given by:
#4
A K14 will fit on your T2 manifold, iv done that before
Reply
Thanks given by:
#5
Sweet that gives me some options, any advantages to either one of them?

Ive just whipped the cooler off and there is hardly any oil in there or in the pipes, nothing unusual, now has me wondering if it was the turbo and what was makong the grinding type noise, plenty of oil in her, gonna take the turbo off and investigate i think!
Reply
Thanks given by:
#6
check your aux belt hasn't shredded and got caught up in your timing belt, sounds exactly like when that happened to me, put the pump timing out and wouldn't hardly start . . .Smile
Phase 1 D-Turdo, K14@24 psi, De-cat, meaty backbox, Bosch pump, grinded LDA pin, duel air fed K&N =133.7bhp & 188ft/lbs
Reply
Thanks given by:
#7
^ This.
Reply
Thanks given by:
#8
Mattcheese you sir are a hero haha, looks like that is exactly whats happened, aux belt is off track with parts of it in the cambelt, gonna check the timing tomorrow, just praying that ive not destroyed the valves!
Reply
Thanks given by:
#9
(12-05-2014, 09:36 PM)philpemberton94 Wrote: Mattcheese you sir are a hero haha, looks like that is exactly whats happened, aux belt is off track with parts of it in the cambelt, gonna check the timing tomorrow, just praying that ive not destroyed the valves!

haha no worries mate, my guess is you'll be ok, you'll need to change the Cambelt though obviously Smile
Phase 1 D-Turdo, K14@24 psi, De-cat, meaty backbox, Bosch pump, grinded LDA pin, duel air fed K&N =133.7bhp & 188ft/lbs
Reply
Thanks given by:
#10
Should be fine, I've had the above happen twice to my pug, was a newish belt and no f*cks where given, so I literally re timed it and off it went - both times haha
Reply
Thanks given by:
#11
Yeah i hope so! Happened to a mate of mine aswell, ive got a new cambelt here ready to go on now, just need get a new aux belt and hopefully we will be away!
Reply
Thanks given by:
#12
Don't bother with aux belt yet, literally do the belt and get it timed up, see if it runs/starts if all is well then get aux belt
Reply
Thanks given by:
#13
Locked the crank in TDC yesterday and it was 1 tooth out on the cam and 3 on the pump!! Could have been messy if it was the other way round! Timed it up and replaced the belt and tensioners, fired her up and she runs like a dream, Just got to get an aux belt now and she will be good as new!
Reply
Thanks given by:
#14
(14-05-2014, 08:29 AM)philpemberton94 Wrote: Locked the crank in TDC yesterday and it was 1 tooth out on the cam and 3 on the pump!! Could have been messy if it was the other way round! Timed it up and replaced the belt and tensioners, fired her up and she runs like a dream, Just got to get an aux belt now and she will be good as new!

good to hear mate, i knew what it was from your description, exactly same happened to me Smile
Phase 1 D-Turdo, K14@24 psi, De-cat, meaty backbox, Bosch pump, grinded LDA pin, duel air fed K&N =133.7bhp & 188ft/lbs
Reply
Thanks given by:


Possibly Related Threads…
Thread Author Replies Views Last Post
  Soo.. Pugs died :/ Seb_Ryan 7 1,655 27-01-2013, 05:32 PM
Last Post: ozonehostile

Forum Jump:


Users browsing this thread: 1 Guest(s)