Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trying to get my xud back to how it use to be!?
#1
Having a few running issues at the moment, this is how the story goes, had a k14, bosch with ground lda setup, it was happily running 24psi for 20k miles +, until i got a bit bored and upped the boost to 28-30psi, it was great fun but within 2 weeks this happened
   

Sads times, anyway picked up a t2 that had never been adjusted or messed with, swapped them over, replaced the exhaust/inlet gasket, and the d seal..

Fired up straight away after 3 months sitting much to my surprise haha! took it for a drive and it was making 13-14psi as expected, it was coaling like mad as the boost couldnt support the amount of fuel that was going through, so i upped the boost to 19 psi, a lot less coal now but still pretty bad on boost, ive turned the fuelling down a lot now so there is only a slight amount of smoke when onto boost, the problem now is that when giving it a good ragging the boost struggles to build up if that makes sense? will smoke alot and hang around the 10 psi mark unless i let off and re apply the throttle slowly? if that makes sense? i even tried the standard lda pin back in but the problems still there.. from what i can find on here im led to believe it could be the wastegaste being weak and being forced open? or that the pump is losing pressure at higher revs? i could be completely wrong but hey!

Sorry to go on but any help or ideas would be greatly appreciated!

Cheers Mitch.
Blaze '6 and Blaze D-turbo!
Reply
Thanks given by:
#2
Respray it a decent colour, thatl fix it
Reply
Thanks given by:
#3
Sounds like a boost leak to me mate, check all the hoses and go from there
Supercharged XUD Project - Dead

HDi Cabby Project Click
Reply
Thanks given by:
#4
(28-04-2013, 08:13 PM)londondan86 Wrote: Sounds like a boost leak to me mate, check all the hoses and go from there

ive tried them all, all seem ok, unless it could be leaking out of the d seal, ill take it off either tomorrow or tuesday and have a look!
Blaze '6 and Blaze D-turbo!
Reply
Thanks given by:
#5
Are you sure the manifold gasket sealed properly?
Supercharged XUD Project - Dead

HDi Cabby Project Click
Reply
Thanks given by:
#6
(28-04-2013, 10:36 PM)londondan86 Wrote: Are you sure the manifold gasket sealed properly?

I cleaned the back of the head up and the face of the manifold when I put it back together, I can spray wd down the back of there whilst its running and the revs don't alter or anything
Blaze '6 and Blaze D-turbo!
Reply
Thanks given by:
#7
Sounds very strange. Who was the T2 off of?

I'd probably turn the fuel right down and adjust the idle so it's more or less back to standard boosting 14 psi and start over from there. If all is well until say 18 psi then it might be wastegate related. I don't think T2 wastegates were designed to be holding back 20+ psi and can creep open hence why a lot of people opt to weld it shut it purchase expensive after market ones like Pompey.
Supercharged GTi6 Build
S14 Zenki Build
[Image: signature.png]
Reply
Thanks given by:
#8
Hmm, my T2 helb boost up to 30psi no problem. I always thought it was pointless to weld up the gate on a small turbo...

To the op, get under it and have a feel of the wastegate arm and see if it feels loose, I still have my money on a boost leak of some sort for now though
Supercharged XUD Project - Dead

HDi Cabby Project Click
Reply
Thanks given by:
#9
He changed the air filter today which apparently has helped alot!
Reply
Thanks given by:
#10
(29-04-2013, 02:50 PM)silverzx Wrote: Sounds very strange. Who was the T2 off of?

I'd probably turn the fuel right down and adjust the idle so it's more or less back to standard boosting 14 psi and start over from there. If all is well until say 18 psi then it might be wastegate related. I don't think T2 wastegates were designed to be holding back 20+ psi and can creep open hence why a lot of people opt to weld it shut it purchase expensive after market ones like Pompey.

T2 came from french car breakers in stafford, thats pretty much what i have tried, it was still doing it and the more i turned it back the slower it got, as stephen said i changed the air filter earlier today as it wasnt in the best condition and this seems to of helped alot (my fault i sort of over looked it being a simple problem) boost has increased to 21 psi now and theres alot more turbo noises so it seems that its breathing better now

   
the old filter, gone to a better place now i.e. the bin lol

(29-04-2013, 07:33 PM)londondan86 Wrote: Hmm, my T2 helb boost up to 30psi no problem. I always thought it was pointless to weld up the gate on a small turbo...

To the op, get under it and have a feel of the wastegate arm and see if it feels loose, I still have my money on a boost leak of some sort for now though

my k14 held high boost fine as well, i had a look at the arm and it is pretty strong, air filter seems to of made it a hell of alot better, ill change the fuel and oil as well tomorrow, and slowly start increasing the fuel again!
Blaze '6 and Blaze D-turbo!
Reply
Thanks given by:
#11
This is why you want to run de-filter. No restriction! Tongue
Supercharged GTi6 Build
S14 Zenki Build
[Image: signature.png]
Reply
Thanks given by:
#12
(30-04-2013, 10:14 PM)silverzx Wrote: This is why you want to run de-filter. No restriction! Tongue

Its pulling really well now, sat behind a 150cdti astra anyway Wink
Blaze '6 and Blaze D-turbo!
Reply
Thanks given by:
#13
it's always the simple stuff that we over look, glad it's sorted now Smile
Reply
Thanks given by:


Forum Jump:


Users browsing this thread: 1 Guest(s)