Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Radiator Fan Not Working?
#1
Hey guys, 
Have a few issues here, the fans do not come on. 
I do however have a bit of a leak in the system, and a new rad is on order, But is the fact it wont hold pressure the cause for the fans to not come on?

Btw shes a
year 2000
2.0l Cabriolet


Tony.
Not always Grumpy!!
306 Cabby SE, 2.0l 16v 
To the optimist, the glass is half full. To the pessimist, the glass is half empty. To the engineer, the glass is twice as big as it needs to be!

Reply
Thanks given by:
#2
is there a fan switch on the rad??? if so take the wire out and put a wire across both wire. if that works replace the fan switch.
306 HDI 
stage 1+ remap
piper cross air filter
hoffmann race centre pipe
hoffmann de-cat pipe
sportex rear tailbox 3"




Reply
Thanks given by:
#3
sweet, will try that asap. Smile
Not always Grumpy!!
306 Cabby SE, 2.0l 16v 
To the optimist, the glass is half full. To the pessimist, the glass is half empty. To the engineer, the glass is twice as big as it needs to be!

Reply
Thanks given by:
#4
Did it work??
306 HDI 
stage 1+ remap
piper cross air filter
hoffmann race centre pipe
hoffmann de-cat pipe
sportex rear tailbox 3"




Reply
Thanks given by:
#5
:embarrassed:

I have not had chance to yet, been so hectic here. i am hoping tomorrow is the day my new rad is here, if it arrives, i will be working on the car, so i will double check then Smile
Not always Grumpy!!
306 Cabby SE, 2.0l 16v 
To the optimist, the glass is half full. To the pessimist, the glass is half empty. To the engineer, the glass is twice as big as it needs to be!

Reply
Thanks given by:
#6
Assuming it has AC (does a cabby need ac!?) there will be 3 sensors on the stat housing. Unplugging one of these (can't remember which off top of my head, someone else will) should bring the fans on as a failsafe.

If anything, a leak should bring the fans on more! So I will guess that you have another fault...
Reply
Thanks given by:
#7
If the sensor is in am air pocket it won't read the true temperature

https://www.check-mot.service.gov.uk/
GTI6 Info

Don’t drive faster than your guardian angel can fly.

Reply
Thanks given by:
#8
Well, i have now fitted my new radiator,

EIS Radiator from Eurocar parts, she now holds a steady 70c Smile she was sat there for 20 mins at that temp. so im happy there.

The fans Do work, as i unpluged the middle plug, and they both came on. and yes, it does have aircon. but it does not get cold. so i think the system needs a re-charge.

So, because i have air-con, how do i go about making sure the system is ok. or is it something i will have to just wait and see on?


Tony.
Not always Grumpy!!
306 Cabby SE, 2.0l 16v 
To the optimist, the glass is half full. To the pessimist, the glass is half empty. To the engineer, the glass is twice as big as it needs to be!

Reply
Thanks given by:
#9
have the system vacuum tested, if it holds, get it charged with a leak detecting dye, off you go.

it wont affect the operation of the fans insofar as they will still cool the engine sufficiently, but they do operate differently when the AC is on.
need a part number? http://public.servicebox.peugeot.com/ and http://service.citroen.com/ will sort you out.
Reply
Thanks given by:
#10
thanks for the reply.

I will look into getting the system checked asap. Smile

Tony.
Not always Grumpy!!
306 Cabby SE, 2.0l 16v 
To the optimist, the glass is half full. To the pessimist, the glass is half empty. To the engineer, the glass is twice as big as it needs to be!

Reply
Thanks given by:


Forum Jump:


Users browsing this thread: 1 Guest(s)